1.17 Support

1.17 Support

Hi Everyone! A small update to let you know that Cryptonia now fully supports 1.17 clients. Most of our backend servers are still on 1.16, however a select few existing servers will be upgrading to 1.17 - with new servers being 1.17 native.

If you have issues joining on 1.17 (Java Edition):
Try joining with the following ip: cryptonia.in:25575

Edit (02/07/2021): As of now Minecraft Education v1.14.70 is now supported.